Make Infinity SDK compatible with Visual Studio 2017

Visual Studio 2017 was released to the public on March 7, 2017. However, the Infinity SDK is not currently compatible with it. It  works with 2013 and 2015.

  • Nancy Franklin
  • Jan 26 2018
  • Shipped
Organization Name (Please enter full organization name) U.S. Naval Academy Alumni Association
Reported Version 4.0
  • Aug 9, 2019

    Admin response

    This was shipped in Service Pack 21.

  • Attach files
  • Mike S commented
    11 Feb, 2019 08:32pm

    Q3 service pack?? Might want to put Visual Studio 2019 support on the backlog now since that'll be out before this is released.

  • Admin
    Poornima Rao commented
    30 Jan, 2019 05:14pm

    We are currently investigating to determine the technical effort and will slate to our Q3 SP this year.

  • Guest commented
    25 Jan, 2019 10:43pm

    Planned for when? :)  And, Yay!

  • Joshua Wrye commented
    3 Aug, 2018 04:12pm

    Hello, I'd like to check on the status of this item. Does Blackbaud have plans to update the SDK to make it compatible with VS 2017?

  • Guest commented
    3 Jul, 2018 12:55pm

    What's the status here?

  • Guest commented
    23 Mar, 2018 01:37pm

    Looking forward to have it compatible with the report creation and report deployment with newer versions. 

  • garrett keating commented
    26 Jan, 2018 02:45pm

    This needs to be on someones radar at Blackbaud. 2017 was released to the pubic March of 2017. It was also available in preview even before that.  I would expect Blackbaud to at least have some plan on when a compatible version of the SDK would be available.